Le 16 septembre 2026, l’infrastructure technique du registre du .lu est mise à niveau. À l’exception de la génération et de la publication de la zone .lu, tous les paramètres techniques de l’infrastructure ont été revus. Certaines des évolutions ainsi implémentées bénéficient directement aux bureaux d’enregistrements accrédités pour commercialiser les noms de domaine en .lu, y inclus l’activité de bureau d’enregistrement de Restena gérée sous my.lu.
Quelles sont les principales évolutions pour les bureaux d’enregistrements ?
- Le serveur EPP ajoute les extensions EPP correspondant aux RFC FEE (RFC8748: Registry Fee Extension for the Extensible Provisioning Protocol (EPP)) et RFC MAINTENANCE (RFC9167: Registry Maintenance Notification for the Extensible Provisioning Protocol (EPP))
- Le serveur NSTest teste le protocole TCP (Transmission Control Protocol) et l’extension EDNS0 (Extension mechanisms for DNS) en complément du protocole de transport UDP (User Datagram Protocol).
- Une redondance actif-actif est mise en place pour les serveurs EPP et NSTest par le biais de plusieurs adresses IP et l’intégration des enregistrements SRV et SVCB.
- Les serveurs EPP et NSTest sont joignables via de nouveaux noms d’hôte unique :
- epp.dns.lu et epp.ote.dns.lu, pour accéder au serveur EPP sous, respectivement, le serveur de production et le serveur de l’environnement de test ;
- nstest.dns.lu et nstest.ote.dns.lu, pour accéder au serveur NSTest sous, respectivement, le serveur de production et le serveur de l’environnement de test.
- Un accès RDAP est ajouté et accessible tant sur le serveur de production – où il complète le WHOIS – que sur le serveur de l’environnement de test, via, respectivement, les adresses web : https://dns.lu/rdap/ et https://dns.lu/test-rdap/.
L’ensemble des évolutions techniques sont reprises dans la dernière édition de la documentation – disponible en version anglaise uniquement – détaillant la politique et les spécifications du système au registre du .lu intitulée ‘The .lu Registry System’.
Le serveur NSTest est un service permettant aux bureaux d’enregistrement de tester la bonne configuration de leurs serveurs de noms. Il s’assure de leur conformité envers les exigences techniques émises par le registre du nom de domaine avant de valider la délégation DNS. La réussite à cette phase de test garantit aux bureaux d’enregistrement la publication dans la zone racine de tous les domaines qu’ils ont en gestion.
Le serveur EPP (Extensible Provisioning Protocol) est un service permettant aux bureaux d’enregistrement d’automatiser la gestion des noms de domaine enregistrés dans une zone. Grâce à lui, les bureaux d’enregistrement gèrent leurs noms de domaine tout au long de leur cycle de vie (enregistrement, modification et libération). Le protocole EPP sur lequel est construit le serveur EPP est défini dans une série de documents de référence technique publiés par l’Internet Engineering Task Force (IETF), et couvrant les RFC5730, RFC5731, RFC5732, RFC5733 et RFC5734.
Le RDAP est un service de consultation des données d’enregistrement des noms de domaine enregistrés dans une zone. Il comprend des informations essentielles pour contacter le titulaire d’un nom en cas de problèmes techniques ou autres et transmet les données de manière automatisée et structurée. Le RDAP est le successeur du WHOIS. Son protocole technique est défini dans une série de documents de référence technique publiés par l’Internet Engineering Task Force (IETF), et couvrant les RFC7480, RFC7481, RFC9082, RFC9083 et RFC9224.
Une évolution indispensable
Une première depuis 2006 et la mise en place du réseau de bureaux d’enregistrement des noms de domaine en .lu, la mise à niveau de l’infrastructure technique du .lu était devenue indispensable. Cette dernière a certes connu des ajustements sur ces 20 dernières années, avec notamment l’implémentation du protocole DNSSEC (Domain Name System Security Extensions) ou bien encore du Nom de domaine internationalisé (IDN), mais rien de comparable avec cette opération de grande ampleur. Celle-ci permet non seulement de déployer l'accumulation des changements préparés par l’équipe du .lu ces dernières années mais surtout de bénéficier d’une base technique améliorée pouvant, notamment répondre aux exigences imposées par les nouvelles directives européennes en terme de sécurité - notamment le Network information System Security 2 Act (NIS 2).
La technologie DNSSEC (Domain Name System Security Extensions) authentifie les enregistrements DNS par des clés cryptographiques garantissant une intégration parfaite de chaque domaine dans une chaîne de confiance au sein de l’arborescence du système de nommage sur Internet.
Un IDN ou Nom de domaine internationalisé utilise des caractères supplémentaires au jeu de caractères standard ASCII (a-Z, 0-9) offrant une plus large possibilité d’enregistrement et de communication.