On 16 September 2026, the technical infrastructure of .lu has been upgraded. Except for the generation and publication of the .lu zone, all the technical parameters of the infrastructure have been reviewed. Some of the changes implemented directly benefit registrars accredited to sell .lu domain names, including Restena’s registrar activity managed via my.lu.
What are the main developments affecting registration offices?
- The EPP server adds the EPP extensions corresponding to the RFC FEE (RFC8748:Registry Fee Extension for the Extensible Provisioning Protocol (EPP)) and RFC MAINTENANCE (RFC9167: Registry Maintenance Notification for the Extensible Provisioning Protocol (EPP)).
- The NSTest server tests the TCP (Transmission Control Protocol) protocol and the EDNS0 (Extension mechanisms for DNS) extension in addition to the UDP (User Datagram Protocol) transport protocol.
- Active-active redundancy is implemented for the EPP and NSTest servers through the use of multiple IP addresses and the integration of SRV and SVCB records.
- The EPP and NSTest servers can be accessed via new, unique hostnames:
- epp.dns.lu and epp.ote.dns.lu, to access the EPP server on the production server and the test environment server, respectively;
- nstest.dns.lu and nstest.ote.dns.lu, to access the NSTest server on the production server and the test environment server, respectively.
- An RDAP access has been added and is accessible both on the production server – where it complements the WHOIS – and the test environment server, via the web addresses https://dns.lu/rdap/ and https://dns.lu/test-rdap/, respectively.
All technical changes are set out in the latest edition of the documentation – available in English only – detailing the policy and specifications of the .lu registry system, entitled ‘The .lu Registry System’.
The EPP (Extensible Provisioning Protocol) server is a service that enables registrars to automate the management of domain names registered within a zone. It allows registrars to manage their domain names throughout their lifecycle (registration, modification and release). The EPP protocol on which the EPP server is based is defined in a series of technical reference documents published by the Internet Engineering Task Force (IETF), including RFC5730, RFC5731, RFC5732, RFC5733 et RFC5734.
The NSTest server is a service that enables registrars to test the correct configuration of their names servers. It ensures that they comply with the technical requirements set by the domain name registry before validating the DNS delegation. Success in this testing phase guarantees registrars that all the domains they manage will be published in the root zone.
The RDAP is a service to look up domain name registration data for a given zone. It includes essential information for contacting the owner of a name in case of technical or other problems and transmits the data in an automated and structured manner. The RDAP is the successor to WHOIS. Its technical protocol is defined in a series of technical reference documents published by the Internet Engineering Task Force (IETF), including RFC7480, RFC7481, RFC9082, RFC9083 and RFC9224.
An essential development
For the first time since 2006 and the build-up of the network of .lu domain name registrars, upgrading the technical infrastructure of the .lu domain had become essential. Whilst adjustments have certainly been made over the last 20 years – notably with the implementation of the DNSSEC (Domain Name System Security Extensions) protocol and Internationalised Domain Names (IDNs) – nothing has been on the same scale as this major operation. It not only enables the roll-out of the accumulated changes prepared by the .lu team in recent years but, above all, provides an improved technical foundation capable of meeting the security requirements imposed by new European directives – notably the Network Information System Security 2 Act (NIS 2).
DNSSEC (Domain Name System Security Extensions) technology authenticates DNS records using cryptographic keys to ensure that each domain fits perfectly into a trusted chain within the tree of the Internet-based naming system.
An internationalized domain name, or IDN, uses characters beyond the standard ASCII character set (a-Z, 0-9), offering a wider range of registration and communication options.